Thread titleFromLast replied
Now searching...
Neoseeker Forums » » » Star Wars: Knights of the Old Republic 2 - The Sith Lords » Nar Shaddaa glitch » Post Reply

Note to Guests: For the enjoyment of other visitors, and to help keep this forum tidy and working smoothly, please make sure you search the forum before posting your question.
REPLY TO A THREAD
Name:* Members, please LOGIN before posting
Email: We use this to display your Gravatar

Sign in with
Subject:*
Message:*


HTML is not allowed
markup is allowed

Help with markup tags

Enabling Buttons in IE7




Smilies:
  ·all smilies here
:) :P ;) :( :| ;( :D :confused: :cool: :# :o ^_^ :colored: :thick:

hideOriginal Post

Jun 11, 06 at 5:09pmronaldhealingo


Hey all, I've just started this game for the second time and I've got stuck on Nar Shaddaa (first place I went to after Telos). I've done everything I can think of expcept play some guy at Pazaak or whatever it's called, because that would mean I have to learn how to play it and I can't be assed nor can I see how this would effect my overall game progress, and the game's just not advancing. Normally there's a fight when you go back to the Ebon Hawk and I've had the journal update telling me to check on it, so I went back there and nothing happened. So I've spend about 2 hours wandering round looking for anything to do, done every little thing I can think of (bar Pazaak) and the game's still not advancing!!

I've heard of a few people saying there's a glitch on Nar Shaddaa or something, is it this it? Is there any way I can get around it? Any help would be greatly appreciated as it's doing my nut in! Thanks in advance.

Thread Recap (last 10 posts from newest to oldest)

May 08, 14 at 11:05am
justhelping


I had the same problem. What helped me was talking to the disgruntled bounty hunter and getting the rundown on the bounty hunter guild, members, law etc. After that, my next zone I got the Red Eclipse trigger.



Jan 02, 14 at 5:12pm
TwitchSapphire


I encountered this same glitch, except I was stupid and just went on to Onderon/Dxun. (I usually do Onderon last.) When I went back to Nar Shaddaa and attempted to bypass that glitch, it didn't work. I was hoping to be able to fix this but I'll have to start back at Korriban... Fail level: Expert.



Jun 14, 13 at 9:42am
Dustin


Try boarding and getting off the ebon hawk. You should get a message.



Dec 19, 12 at 12:29pm
Orangetictac


Hi everyone I'm new to this site. I actually found this site from doing a Google search for Knights of the Old republic 2 glitches PC.

I have played both KOTOR games multiple times back in the days when I had them for my Xbox. I had a bit of a craving to play these games so I bought both games for the PC.

I played through the first game 3 times one for each character type and one time I had the main character be a female.

Then I went ahead and started playing through the 2nd game. Every once in awhile the game would freeze up and my computer would automatically shut it down. I would get a little angry and re-load the game and have to re-play the portions of the game that I did not save. This was just a minor annoyance.

I played all the way through the Dantooine level mainly because I remembered that I could get almost all the light saber parts from the scavengers and one final piece from master Vrook. Since this is a Star Wars game a force user should have a light saber after all.

I then went through the Onderon/Duxon level mainly so that I could get Canderous Ordo/ Mandalore to join my party.

After escaping Onderon I went to Nar Shaddaa...

I was able to do enough of the little side quests on this level to make the Red Eclipse thugs appear at the Ebon Hawk. I of course fought my way through until I got to the leader and told him that he worked for me now.

I then went back out with Atton where he says that there is an incoming message. The entire crew meets up outside the ship where the ugly squid faced man sends an invitation to meet him in the jekk'jekk tarr.

At this point the game forces you to go solo. I'm on the way to the jekk'jekk tarr when the redheaded bounty hunter has a conversation with me. At the very end of the conversation she says something about my friends being in trouble. The game looks like it is about to cut away to a movie or to another scene and the game kind of pauses for a moment and my computer shuts the game down. I've re loaded and re booted so many times and it does the same thing every time. I'm just a little angry because I know exactly what I need to do but the game won't let me.

Does anyone else have this issue?

I've already beaten this game for the Xbox but I no longer have my old Xbox and I don't think I should have to hunt and purchase an Xbox system and this game in order to successfully play through it successfully.

I deleted my game and uninstalled Knights of the old republic II off my computer.

I've been thinking about possibly re-installing it later and maybe start a new game and just have Nar shaddaa be the first planet I play through to see if I still tweaks.

Are there certain game settings or computer settings that I need to change to help the game play through without shutting down on me?

If anyone has experienced this issue and has found a way to play through the game please feel free to share your knowledge on this matter so that I can play through this game start to finish.

Thanks Orange Tic tac



Jul 13, 12 at 3:46pm
jangomike


after u defeat the exchange boss on naar shardaa an head back to the ship when u get to the main area u get a view of the todarrian talking to the red eclipse boss as u head to the ebon hawk u will start to fight the red eclipse



May 28, 12 at 5:54am
Admiral Caleb


did you go through the pazaak den and told the teddy-bear-looking-person to put in some words about you for 2000 credits? i had no problems when i went through, but then it could be te disk.



Mar 07, 12 at 7:15am
Milo26


Drevan, for The Champs meddal even if you lose you can still get his medal when or if you lose to him you'll get into a conversation he'll chirp "Haha I am champ i never lose!" And to do this you have to have dominate mind AND your persuade skill has to be VERY VERY high like in the 20-30 range. You'll have the option to say (Force persuade) "But not this time." And if it succeeds he'll say "lose no more! Take the medal." and you can only get into this conversation if you lose.



Mar 06, 12 at 8:10am
Milo26


if you want to find the champ battle each person, the female tweelek, fix the robot, and beat the geradi. then you will find the champ, a word of warning HE'S REALLY HARD TO BEAT! if you are a female character you will need Atton to beat the female. you don't even need to battle the bot just fix him.



Mar 06, 12 at 8:06am
Milo26


hey guys if you go to nar shaddaa first and you get ally your lightsaber pieces don't make it just yet... go to the woman, she's in, I forgot what it's called but its the dock or the entertainment place but the third place once you go there just talk to everyone there cause I'm not sure where she is then she'll say she's lost her husband tell her that you'll find him. Then go kill the two exchange guards by the front door. Now go to the dock and find the spot where all the rooms are then look in the room next to the hammerhead alien talk to him and he will say he can't find his wife he's looked everywhere and tell him that you've already found her and that's she's in the place he'll ask that there's two guards there tell him that you killed them he will thank you and leave.Cause if your on the lightside (it only works if your on the light) Mira will talk to you about waving your lightsaber into everyones bizness in your quotation you'll say "But I don't have a lightsaber." She'll say it won't matter and that your friends are the one's in trouble. After you fight the two bounty hunter tweeleks as atton. Go to the man and wife you helped. Save the game then talk to them they will thank you and give you a lightsaber. If you don't get a lightsaber you like just load the game you saved and talk to them again you will get either a short, double, or single bladed lightsaber.



Sep 06, 11 at 4:46pm
Drevan


quote ronaldhealingo
I've walked around Nar Shaddaa for about 3 hours talking to every single person over and over again, even the people that you don't get a conversation box with, and I've been to every stinking corner of the place a dozen times! The only thing I haven't done is beat the champ, but he doesn't seem to be in the Pazaak den? I beat Geradi or whatever he's called, but I don't see the champ anywhere. So there's no other way for me to effect my status with the exchange as far as I can see.
Do the thing with Oondar and the "non-male rodian" and make sure to go with the rodian.



Powered by neoforums v2.3.0 (Bolieve)
Copyright Neo Era Media, Inc. 1999-2014

Neoseeker.com   |   Forum Rules   |   Forum FAQ   |   Neoseeker Terms of Use   |   Supermods On Duty [ server id: web3 ··· elapsed: 0.0801]
Chat and Lounges
Game Platforms
Mobile Platforms