Thread titleFromLast replied
Now searching...
Neoseeker Forums » » » Computer Help and Discussion » PC Not copying and pasting » Post Reply

Note to Guests: For the enjoyment of other visitors, and to help keep this forum tidy and working smoothly, please make sure you search the forum before posting your question.
Name:* Members, please LOGIN before posting
Email: We use this to display your Gravatar

Sign in with

HTML is not allowed
markup is allowed

Help with markup tags

Enabling Buttons in IE7

  ·all smilies here
:) :P ;) :( :| ;( :D :confused: :cool: :# :o ^_^ :colored: :thick:
Community Badges

Join to get access to all the badges!

hideOriginal Post

Apr 28, 13 at 1:49amniallallator

Hi, I just recently got a new pc and whenever i try to copy and paste things all it says is "Discovering Items" but never seems to do anything.

Can someone please help


Windows 7 Professional

Thread Recap (last 10 posts from newest to oldest)

May 16, 13 at 1:29am

I think there's nothing wrong with peripherals but take a look on installed applications. Try uninstalling any third party copier. It will fix this issue for sure.

May 13, 13 at 5:03pm

My bet, your HDD may already have a lot of files that when you open or browse through it, it would take some time for the computer to scan them. While the files populate almost instantaneously, it would still take time for the computer to reach that sector. When you tried copying files, it would say 'Discovering Items' because literally, that's what the computer does.

Wait for a minute or two and it would be fine.

May 13, 13 at 1:11am

It has to put a list of files in a queue so it knows which ones to move. You could try Teracopy, after using it you do not have to depend on the windows copying or deleting queue. Teracopy is fast in copying and pasting.

May 03, 13 at 2:53am

I don't know what happened but I tried copy and pasting from my external hard drive, and the copy and pasting is working again, so I don't exactly know what has happened.

Thanks for the help, and if it stops working again i'll re-post.

Apr 30, 13 at 6:42am

Ten bucks says that the fault lies on the external drive.

I'm thinking it's faulty or failing. Try copying/pasting on other storage devices. If the problem persists, then my ten bucks is wrong.

Apr 29, 13 at 2:20pm

Hi, I've checked around in task manager and couldn't seem to find the program that you were talking about,even though I clicked show all processes from users, could it be that it isn't working because it isn't running??
Also, I'm trying to copy and paste from an external hard drive


Apr 28, 13 at 7:31pm

This is likely a bug on machines running Win7 or latest updates in Vista.
Are you trying to copy files to your new Win7 professional computer from what source (computer/device)? Also, are the files you want to copy from remote to local or vice versa?

Try to kill or terminate the rdpclip.exe process using Task Manager and then run rdpclip.exe to restart it.

The rdpclip.exe or RDP Clip Monitor is the main executable for File Copy, a system process that allows users to copy and paste between server and client. It's a vital program to stabilize and secure running of your Windows 7/XP/Vista computers, located in the folder C:\Windows\System32. While removing this file is not actually recommended, you can stop the process for a moment and then restart it after to refresh.

Apr 28, 13 at 1:49am

Hi, I just recently got a new pc and whenever i try to copy and paste things all it says is "Discovering Items" but never seems to do anything.

Can someone please help


Windows 7 Professional

Powered by neoforums v2.3.5 (Bolieve)
Copyright Neo Era Media, Inc. 1999-2015   |   Forum Rules   |   Forum FAQ   |   Neoseeker Terms of Use   |   Supermods On Duty [ server id: web8 ··· elapsed: 0.2053]
Chat and Lounges
Game Platforms
Mobile Platforms