Thread titleFromLast replied
Now searching...
Neoseeker Forums » » » Computer Help and Discussion » Clock Errors » Post Reply

Thread Recap (last 10 posts from newest to oldest)

Oct 3, 12 at 2:55pm

Well, clock errors are fairly rare and most of the time changing the battery does the trick.

Firstly go to Date and Time in Control Panel and go to Internet Time. Press Change settings... and see if "Synchronise with an internet server" is checked and that it syncs with

Other then that, there is a trick which synchronises your clock on an interval;
First make sure your Windows Time service is running by going to Start > Run.. and type services.msc then locate the service Windows Time and put it on automatic start.

Now type in Task Scheduler and open it.
Find the Microsoft / Windows / Time Synchronization branch and click Create Task...
Give the new task a name and set the new task to run as the LOCAL SERVICE user. Set it to run with highest privileges and to be configured for your OS version.
Set the task to run daily at the time you want. I suggest 1:15am as it's 15 minutes after the default Synchronize Time task.

The task will have two actions. Make sure they end up in the right order. The first action does the same as the original Synchronize Time task and ensures the Windows Time service is running. The second action makes the actual time sync happen.
Set the first action to start a program, which is %windir%\system32\sc.exe with arguments start w32time task_started
Set the second action to start a program, which is %windir%\system32\w32tm.exe with argument /resync

Turn off the setting which makes the task only run on AC power. The task is very brief so there's no reason not to run it when on battery power.
Set the task to start only if a network connection is available. Set the task to run as soon as possible if its schedule is missed.
To test that the task actually works, manually mess up your clock's time and then right-click the task and select Run. Your clock's time should be corrected.

Oct 2, 12 at 6:27pm

The lack of help angers me...*bump*

Sep 25, 12 at 1:45pm

Pedigree i have replaced the battery, and checked the port, and am still getting errors. the time doesn't change on it's own, and everything else is working fine. i tried synching it to an internet time server multiple times, and got an error message saying it failed, without telling me why.

Sep 24, 12 at 12:36am

Though you have tested the battery, have you tried replacing it? Might want to try cleaning the terminals of the battery port as well.

Sep 23, 12 at 9:09am

I have recently been experiencing a problem with the time on my laptop, and have no idea how to fix it. I can reset the clock just fine, but when the computer is off or asleep, time doesn't move forward. I have already tested the CMOS battery, and there are no problems with it. Has anyone else seen anything like this?

Powered by neoforums v3.0.0b
Copyright Neo Era Media, Inc. 1999-2017   |   Forum Rules   |   Forum FAQ   |   Neoseeker Terms of Use   |   Supermods On Duty [ server id: www3 ··· elapsed: 0.0425]
Chat and Lounges
Game Platforms
Mobile Platforms