Thread titleFromLast replied
Now searching...
Neoseeker Forums » » » » Dead Space » Chapter 10 Trick (Glitch Maybe?) » Post Reply

Note to Guests: For the enjoyment of other visitors, and to help keep this forum tidy and working smoothly, please make sure you search the forum before posting your question.
REPLY TO A THREAD
Name:* Members, please LOGIN before posting
Email: We use this to display your Gravatar

Sign in with
Subject:*
Message:*


HTML is not allowed
markup is allowed

Help with markup tags

Enabling Buttons in IE7




Smilies:
  ·all smilies here
:) :P ;) :( :| ;( :D :confused: :cool: :# :o ^_^ :colored: :thick:

Thread Recap (last 10 posts from newest to oldest)

Sep 21, 12 at 4:18am
MrMcCrack


I discovered another glitch in the same area as you are describing. I do the same as you and move the metal bed units to traps the threat instead of fighting them. When I returned to the common room I think it's call, I needed to go up the lift and into the Executive Security Door which I had been told was now open. However this door automatically locked itself when I arrived as the room was full of "monsters". Instead of fighting them I ran straight for the lift and went up to the next level. The game then tried to outsmart me by sending them down through the ceiling. I killed them all but it must have confused the game because the lock down never released. I was stuck in that room with nothing else to kill and not even any way of killing myself.



May 23, 12 at 7:44am
HunterKiller666


Towards the end of the chapter 10, after you've picked up the last nav card, a regenerator will drop from the ceiling. Use stasis on it and then run back to the room with all the metal blockades that you can move with kinesis. A dark necromorph will try to ambush you here but if you are quick enough you can run past it and then move the blockades to block it from reaching you. After that you have to enter a quarantine room, and that's when I discovered this trick.

Instead of going straight into the room and fight around 5-6 necromorphs (at least two dark ones), two dark lurkers, as well as the regenerator, what I did was right after I opened the door to the quarantine room I immediately turned around and ran back a little bit. The regenerator then dropped from the ceiling along with the dark necromorph (probably the same one that I used the blockades to block off before). I killed the necromorph and used stasis on the renegerator, then I went into the room and all that's left in there were two dark lurkers. After killing them both, no more enemies respawned, so all I had to do was stasis the regnerator one more time and wait for Kendra to unlock the doors, which is a hell lot easier than going straight into the room and get locked in and having to fight so many of them at once. I'm not sure if this was caused by a glitch or not, but since I play on Impossible mode I'm thankful I was able to make through this part without dying once. Hope this helps whoever that can make it work like I did.



Powered by neoforums v2.2.0c (toro)
Copyright Neo Era Media, Inc. 1999-2014

Neoseeker.com   |   Forum Rules   |   Forum FAQ   |   Neoseeker Terms of Use   |   Supermods On Duty [ server id: web8 ··· elapsed: 0.1105]
Chat and Lounges
Game Platforms
Mobile Platforms