Thread titleFromLast replied
Now searching...
Neoseeker Forums » » » Starcraft II » Campaign framerate capping bug » Post Reply

REPLY TO A THREAD
Name:* Members, please LOGIN before posting
Email: We use this to display your Gravatar

Sign in with
Subject:*
Message:*


HTML is not allowed
markup is allowed

Help with markup tags

Enabling Buttons in IE7



Smilies:
  ·all smilies here
:) :P ;) :( :| ;( :D :confused: :cool: :# :o ^_^ :colored: :thick:
Note to Guests: For the enjoyment of other visitors, and to help keep this forum tidy and working smoothly, please make sure you search the forum before posting your question.

hideOriginal Post

Aug 04, 10 at 8:17amShinobi_razor


just thought id bring this to everyone's attention here just in case. im not sure if Blizz has fixed this issue yet. the game was patched a few days ago but i dont know if this was fixed.

quote FileFront
If your computer is getting really hot while you play StarCraft II, it’s not because you’re blazing up Battle.net – it’s because the game is roasting your machine alive.

Blizzard has confirmed the game has an overheating bug. Apparently, the game doesn’t cap the frame rate it uses when rendering its menus. So basically, the system goes crazy, overworking itself on rendering the menu, and that causes a big increase in heat.

So much so that if the problem isn’t dealt with, it can damage your computer.
[source]

quick and simple temporary work around until its patched (if it hasnt been yet, but i went ahead and did this anyway):

1. open the file “variables.txt” with Notepad, which should be located in Documents\StarCraft II\. if you cant find it, try searching your comp for it.

2. insert the following lines at the bottom of the file, then save:

frameratecapglue=30
frameratecap=60

Thread Recap (last 10 posts from newest to oldest)

Aug 05, 12 at 6:14am
Ailfawka


this still has not been fixed, while those lines of text for the fps cap in variables cap in game fps and menu fps, there is still the problem in campaign armory/cantein areas that spike like a bitch and cause my gtx 680 to max out and reach 70-75 degrees Celsius. anyone know the fps cap text for that area by any chance? lol



Aug 06, 10 at 8:44am
Cruel Angel Thesis


My friend told me a similar thing about SC2 melting your video card 3 days ago.

quote I can't find the source -_-
Blizzard has confirmed that there is an overheating problem with ‘StarCraft II” that might melt your Video Card. The problem has been identified to be that certain screens in “StarCraft II” will make your computer work twice as hard. Usually, you would think that a screen with a lot of details would overheat your computer, but this time is the screens with less details that are the culprit. Screens with less details are said to cause the game to idle and just primarily draw the screen at a very fast pace which leads to overheating your computer if you do not have a very good cooling system. Certain screens make your hardware work pretty hard Screens that are light on detail may make your system overheat if cooling is overall insufficient. This is because the game has nothing to do

so it is primarily just working on drawing the screen very quickly. A temporary workaround is to go to your Documents\StarCraft II Beta\variables.txt file and add these lines: frameratecapglue=30 frameratecap=60 You may replace these numbers if you want to.
But there's a patch earlier today so do I still have to add that settings in the config?




Aug 05, 10 at 11:07pm
Shinobi_razor


Speed Fan seems to be ok. if youre on Windows 7 i just got an Nvidia temp monitoring gadget that seems to work well.



Aug 05, 10 at 7:38pm
HunterKiller666


How do you guys get the temperature to display?

I tried modifying that file as told, but I haven't noticed my laptop becoming any cooler than before. The air that comes out of that thing is still burning!

The only thing I can do right now is don't play for more than 2 hours at a time so my laptop can get a chance to cool down. They better get that patch out soon.



Aug 04, 10 at 11:15pm
Shinobi_razor


quote MaChaoTheSplendid
Yeah I noticed my comp frying back when I was playing Beta, hell it even got up to 100 degrees Celsius once without me noticing..

I think it may have been patched now though.
it mightve been though i dont think it was. you should just do it anyway, it wont hurt anything to do it and it will force the game to set the cap at 60. 93C on just the menu absolutely should NOT be happening ever. shouldnt really even get that hot playing the game.



Aug 04, 10 at 10:52am
xmaliciousx


Right before I caught this post I saw someone on the official boards ranting about how SC2 killed his computer, so I decided to check my own graphics card to see if he was just an idiot. Boy was I surprised to see my card idling at 93C on just the menu.

I recommend everyone use this workaround as soon as possible to prevent any damage to their hardware, hopefully Blizzard will have that patch out ASAP.




Aug 04, 10 at 9:18am
MaChaoTheSplendid


Yeah I noticed my comp frying back when I was playing Beta, hell it even got up to 100 degrees Celsius once without me noticing..

I think it may have been patched now though.



Aug 04, 10 at 8:17am
Shinobi_razor


just thought id bring this to everyone's attention here just in case. im not sure if Blizz has fixed this issue yet. the game was patched a few days ago but i dont know if this was fixed.

quote FileFront
If your computer is getting really hot while you play StarCraft II, it’s not because you’re blazing up Battle.net – it’s because the game is roasting your machine alive.

Blizzard has confirmed the game has an overheating bug. Apparently, the game doesn’t cap the frame rate it uses when rendering its menus. So basically, the system goes crazy, overworking itself on rendering the menu, and that causes a big increase in heat.

So much so that if the problem isn’t dealt with, it can damage your computer.
[source]

quick and simple temporary work around until its patched (if it hasnt been yet, but i went ahead and did this anyway):

1. open the file “variables.txt” with Notepad, which should be located in Documents\StarCraft II\. if you cant find it, try searching your comp for it.

2. insert the following lines at the bottom of the file, then save:

frameratecapglue=30
frameratecap=60



Powered by neoforums v2.0.3 (toro)
Copyright Neo Era Media, Inc. 1999-2014

Neoseeker.com   |   Forum Rules   |   Forum FAQ   |   Neoseeker Terms of Use   |   Supermods On Duty [ server id: web6 ··· elapsed: 0.1267]
Chat and Lounges
Game Platforms
Mobile Platforms