Thread titleFromLast replied
Now searching...
Neoseeker Forums » » » General Playstation 3 » HELP! PS3 will not let me insert disc. » Post Reply

hideOriginal Post

Dec 31, 09 at 12:34amMistroPain

Not sure if this is the right forum to post this on but I couldnt find a technical related forum.
Anyways, im having issues with my PS3 in that it will not allow me to insert a disc, even when I manually push it all the way in.
If I do manually push it in it wont read, if I dont manually push it in and try to get the PS3 to do the nifty trick and pull the disc in itself it wont do that either.

On the Sony site it sais to keep your hand on the eject button for 10 or 15 seconds, ive done that and nothing happened. Ive also attempted to clean it by sticking a stick wrapped in microfibre cloth, and that has not worked either. Ive also switched my PS3 on and off plenty of times trying to get it to work each time, sometimes unplugging the power in between power on and off but that has not worked either.

Anyone know what the issue might be? Has anyone had this issue?
Help would be much appreciated.

If no one knows I might have to take it to a service shop to get them to inspect it. I hope my warranty covers this.

Thread Recap (last 10 posts from newest to oldest)

Dec 23, 15 at 5:26pm

Take it to EBGames. They repair PS3 for $60 if you don't have the warranty.

Dec 19, 15 at 5:36pm

OK. I came to this site cause my ps3 takes disks but sometimes doesn't go all the way in. The bull shit bout it reading it while in the system can't be true. Just can't. All other systems don't read it while it's off. I've had mine for 3 years and 2 of which it's been sitting on a shelf with a disk in because it had that screen won't show up problem and I just recently looked up on YouTube how to fix that and it worked. Besides why the he'll would they call it an "off " button if it basicly reads it still. It really defeats the purpose.

Jul 13, 14 at 10:01am

Same thing is happening to mines. Can I just take the disc out and let the console cool down for awhile and will It work again?

May 7, 14 at 5:08pm

This is one long ass thread

Jan 28, 14 at 8:51pm

Yes. This did happen with my PS3. All I had to do is old the eject button for 13 seconds, then push the disk in with some force and BAM! Borderlands started. Although I do know this does not work with some, it works with most.
And the only other way is I either order the part and install it yourself or take it to be replaced or serviced. And even if the disk does not get power it is still not the best thing to leave disks in a PS3. And s the ps3 does have power when in idle, unless you turn it off by the wall: proof is that when you do leave it in idle THE LIGHT IS STILL ON!.

Jan 22, 14 at 4:45pm

My ps3 only reads certain disks?some it doesn't read even clean unscratched one's

Dec 25, 13 at 5:35am

GUYS ! I FOUND THE SOLUTION ! Trust me, it works ! I had the exact same problem before doing the following thig. So - turn off your PS3 from the back switch, and while its off put your finger on the eject button . While having your finger there, turn on the console from the back again, and keep your finger there. It will power up and make a hover-like sound. Dont be scared, and keep your finger there for 7 - 10 seconds. Then swotch it off from the back again, then on and power it up normally. It will definitley work ! Have fun !

Dec 23, 13 at 7:33am
Stephen Edwards

My ps3 IsnIsn't allowing no games to go it but I was playing it last night but when I woke up this morning it wouldn't let a game renter so can someone please help me I been having my system since 08 I can't live without it

Dec 18, 13 at 10:50am
jeremy lovejoy

Zero and x, any electrical device that is still plugged into the outlet is receiving a small ammount of power. Or did you think the little red light was powered by magic?

Oct 29, 13 at 2:16pm
Zero and X

quote bradonder
quote Zero and X
Lmao, ok, so a machine is powered by electricity right? So you're trying to propose, that a machine that is designed to work when there is electricity, is somehow magically working when there is no electricity being transmitted into the system?

Wow, the stupidity, it hurts.
Alright I am going to put this to rest right now, first off, they are not referring to the bluray laser, there is a laser diode at the front by the slot that, when tripped, signals the drive to suck a disc in. The disk is not being read while the system is off, yes, flipping the switch would fix this but not everyone does.that cuz it means to walk to the system. If almost ANY electronic device is plugged in, it draws a low level current so that buttons can 'listen' for activation, usually a power button. So don't ASSUME things cuz u think u understand it, have a nice day:D
I find it incredibly annoying when people randomly quote things I said years ago. Seriously dude, this conversation was dead for years, what exactly were you trying to prove?

Powered by neoforums v2.3.9 (Bolieve)
Copyright Neo Era Media, Inc. 1999-2016   |   Forum Rules   |   Forum FAQ   |   Neoseeker Terms of Use   |   Supermods On Duty [ server id: www3 ··· elapsed: 0.0665]
Chat and Lounges
Game Platforms
Mobile Platforms