Neoseeker : : : : ECS HDC-I Motherboard Review

ECS HDC-I Motherboard Review - PAGE 7

- Wednesday, June 15th, 2011 Like Share






Get updates when we publish new articles

Comments

Sort by date: ascending descending
0 thumbs!
^
dakky21 Nov 5, 11
quote leochan
ECS has jumped on the AMD Fusion bandwagon with the HDC-I, which boasts some great features such as integrated WiFi and Bluetooth. It's even got one-touch overclocking through a Turbo Mode. See if this mini ITX motherboard can do the Fusion platform proud in our review.

http://www.neoseeker.com/Articles/Hardware/Reviews/ecs_hdc-i/
I came on this board just to say that... not ALL boards have overclock function !!!!

I just bought HDC-I v1.0 yesterday, in fact only because I read it had overclock option, but what a cold shower - it does not have. At least not where it should be, under Frequency/Voltage control in BIOS. Maybe there is a key binding to enter it, but on default, it is not showed.
0 thumbs!
^
The Smith Nov 6, 11
quote dakky21
I came on this board just to say that... not ALL boards have overclock function !!!!

I just bought HDC-I v1.0 yesterday, in fact only because I read it had overclock option, but what a cold shower - it does not have. At least not where it should be, under Frequency/Voltage control in BIOS. Maybe there is a key binding to enter it, but on default, it is not showed.
I can confirm there is no key binding to do. Which BIOS version do you have?
0 thumbs!
^
dakky21 Nov 7, 11
I had to register to post a reply... anyway...

I've got the BIOS version 2.10.1208 as shown in the picture:
(03/24/2011)


Also another pic that is proof for what I say - there is no turbo mode.



I bought this board because of lots of reviews, all of them told me there is a Turbo Mode, but my board doesn't have it. It seems ECS intentionally shipped "good" boards to reviewers and bad one to the shops.

Just to warn anyone who is consider this board as an option...
0 thumbs!
^
The Smith Nov 7, 11
Hi dakky21,

The BIOS on the tested board is dated 04/08/2011. Seeing yours is older, I suggest you try to update your BIOS to a newer one using the eBLU utility. Let me know if this works out.
0 thumbs!
^
dakky21 Nov 7, 11
quote The Smith
Hi dakky21,

The BIOS on the tested board is dated 04/08/2011. Seeing yours is older, I suggest you try to update your BIOS to a newer one using the eBLU utility. Let me know if this works out.
Where can I find that utility, I'm pretty sure I've looked the entire ECS site :-)
0 thumbs!
^
dakky21 Nov 7, 11
Nevermind, I found it, but it says no updates found.

0 thumbs!
^
The Smith Nov 7, 11
I asked ECS' representative about this issue. I will let you know when I get a reply.
0 thumbs!
^
foster12345 Nov 19, 11
Can anyone save the new BIOS version, and send it to us? He can use this program: http://downloads.zotac.com/mediadrivers/mb/bios/pa192.zip
Dakky and I would be happy!





Thank you, and sorry for the bad English (google translate )
0 thumbs!
^
The Smith Nov 19, 11
Sadly enough, I have not got a reply from the representative.

I can upload the BIOS, but neither I nor Neoseeker is responsible for anything that goes wrong. In the case of a bricked board, you will need to go through the RMA procedure.
0 thumbs!
^
foster12345 Nov 19, 11
I promise that I shall bear all the consequences. I would never blame Neoseeker and you!
Thanks!
0 thumbs!
^
The Smith Nov 20, 11
Here is the BIOS, saved with the utility you mentionned above.

Also, here is a pic of what to expect.

Good luck, let us know how it ends up.
0 thumbs!
^
foster12345 Nov 20, 11
The Smith, Thank you so much! I did it! Everything is fine, and thank you very much! Give me the address to send you a beer
Here is the proof:


http://s11.postimage.org/4y6lstyr7/screenshot_4.jpg
p.s. And dakky and will be happy! Should have imagination, and good people like "The Smith"

Thank you once again!
0 thumbs!
^
The Smith Nov 20, 11
quote foster12345
The Smith, Thank you so much! I did it! Everything is fine, and thank you very much! Give me the address to send you a beer
Here is the proof:


http://s11.postimage.org/4y6lstyr7/screenshot_4.jpg
p.s. And dakky and will be happy! Should have imagination, and good people like "The Smith"

Thank you once again!
Very Nice! I'm glad it worked.

I'll send a message to Dakky to make sure he doesn't miss this one.

Stay tuned for more great articles.
0 thumbs!
^
foster12345 Nov 20, 11
Hello, As you may know from previous posts, BIOS problem was solved (thanks to The Smith). Turbo mode works, but when I run video with VLC player, video freezes (without the turbo does not). Not much, but enough annoying. Does anyone know maybe why is this so? Where I'm wrong, because everything else (surfing, youtube) is much faster and better!

I would be grateful for answers!
^
Sponsored
Sort by date: ascending descending
Add your comment:
Name *:  Members, please LOGIN
Email:  We use this to display your Gravatar.

Sign in with
Comment *:
(0.2045/d/web6)